Opened 4 years ago

Last modified 4 years ago

#247 new enhancement

Checking for packages with security vulnerabilities: cron mail output warnings

Reported by: rick Owned by: nobody
Priority: minor Milestone: WL-11.2-RELEASE
Keywords: Cc:
Resource needed to fix:

Description

Since we are post-removing files which are normally part of the package, this yields into errors on integrity checks. Some examples:

Checking for packages with mismatched checksums:
GeoIP-1.6.12: missing file /usr/local/share/doc/GeoIP/COPYING
GeoIP-1.6.12: missing file /usr/local/share/doc/GeoIP/ChangeLog
GeoIP-1.6.12: missing file /usr/local/share/doc/GeoIP/LICENSE
GeoIP-1.6.12: missing file /usr/local/share/doc/GeoIP/README.md
apache24-2.4.37: missing file /usr/local/share/doc/apache24/BUILDING
apache24-2.4.37: missing file /usr/local/share/doc/apache24/LICENSE
apache24-2.4.37: missing file /usr/local/share/doc/apache24/NOTICE
apache24-2.4.37: missing file /usr/local/share/doc/apache24/bind.html
apache24-2.4.37: missing file /usr/local/share/doc/apache24/bind.html.de
apache24-2.4.37: missing file /usr/local/share/doc/apache24/bind.html.en
apache24-2.4.37: missing file /usr/local/share/doc/apache24/bind.html.fr.utf8
...

We should check whether we can reduce the image size by properly leaving out packages and/or compile packages without documentation options.

Change History (1)

comment:1 by rick, 4 years ago

Summary: Checking for packages with security vulnerabilities:Checking for packages with security vulnerabilities: cron mail output warnings
Note: See TracTickets for help on using tickets.