Opened 12 years ago

Closed 12 years ago

Last modified 10 years ago

#34 closed defect (fixed)

named out of swap space (test of image-r6873)

Reported by: huub Owned by: rick
Priority: major Milestone:
Keywords: Cc:
Resource needed to fix:

Description

Named is gestopt na een dag met de boodschap:
2009 Apr 26 15:00:03 <kern.err> kernel: pid 911 (named), uid 53, was killed: out of swap space

Tim is dit probleem ook tegen gekomen (zie ticket).

CNodeHuub# df
Filesystem 1K-blocks Used Avail Capacity Mounted on
/dev/ad0s1a 243592 166384 57720 74% /
devfs 1 1 0 100% /dev
/dev/md0 4526 2184 1980 52% /etc
/dev/md1 4526 1716 2448 41% /var
devfs 1 1 0 100% /var/named/dev

Change History (7)

comment:1 by rick, 12 years ago

Milestone: 0.1

comment:2 by rick, 12 years ago

Resolution: fixed
Status: newclosed

Set named not to be authoritative for all zones, but only forwarder. which will solve this, as it does not require to fetch a whole lists of non-existing files leaving all kind of stale handled open.

bq. out of swap space

Generally caused by running to many processes on the box, causing the memory consumption to go haywire, leading to kill all kind of processes.

comment:3 by huub, 12 years ago

Resolution: fixed
Status: closedreopened

Running revision nr 7121 on testnode huub named crashes after some time :
Aug 13 21:28:44 CNodeHuub kernel: pid 890 (named), uid 53, was killed: out of swap space

comment:4 by huub, 12 years ago

Named is using a lot of memory: 15 MB immediately after startup which gradually increases to 30 MB.

I have tried to minimize memory usage by modifying named.conf options as follows:
max-cache-size 5m; maximum cache size of 5 MB
cleaning-interval 15;
clean cache every 15 minutes
max-cache-ttl 60; limit cached record to a 60s TTL
max-ncache-ttl 60;
limit cache neg. resp. to a 60s TTL

(this is suggested in DNS & BIND Cookbook, p.78)

However this did not make any difference!
Also running rndc flush does not reduce named memory usage on NodeHuub

I also noted that on a FreeBSD6.0 node named only uses 9 MB (on nodeIMI, uptime 77 days).
On NodeCeTIMs, FreeBSD 5.0, uptime 236 days, I see following memory use:
CeTIM 1, 2, and 3 respectively: 4.0 MB, 3.0 MB and 23.5 MB.

comment:5 by huub, 12 years ago

On NodeDirkLos2, running Tim Baas config of FreeBSD7.1, uptime 66 days, the memory usage of named is 16 MB.
This node is running bind 9.6.0-P1 (NodeHuub is running 9.4.3-p2).

comment:6 by huub, 12 years ago

Resolution: fixed
Status: reopenedclosed

Rick has replaced named (and dhcpd) bij dnsmasq which uses only about 3 MB. NodeHuub appears to be very happy with this change!

comment:7 by rick, 10 years ago

Milestone: 0.1

Milestone 0.1 deleted

Note: See TracTickets for help on using tickets.