Opened 6 years ago

Closed 6 years ago

#648 closed change (fixed)

RekPark303; Geen Internet

Reported by: henk Owned by:
Keywords: Cc:
Location: Generiek

Description

Wel verbinding naar de node, maar geen Internet mogelijk.
Zowel via de repeater als direkt naar de node zijn getest.

Change History (5)

comment:1 Changed 6 years ago by ed

Volgens de config files is er een extra repeater geplaats op een boot welke het zelfde ip-nummer
heeft als de interface van de node met als gevolg.

HybridRekpark303# dmesg
arp: dc:9f:db:3e:27:4f is using my IP address 172.17.154.3 on vr0!
arp: dc:9f:db:3e:27:4f is using my IP address 172.17.154.3 on vr0!
arp: dc:9f:db:3e:27:4f is using my IP address 172.17.154.3 on vr0!
arp: dc:9f:db:3e:27:4f is using my IP address 172.17.154.3 on vr0!
arp: dc:9f:db:3e:27:4f is using my IP address 172.17.154.3 on vr0!
arp: dc:9f:db:3e:27:4f is using my IP address 172.17.154.3 on vr0!
arp: dc:9f:db:3e:27:4f attempts to modify permanent entry for 172.17.154.3 on vr0
arp: dc:9f:db:3e:27:4f attempts to modify permanent entry for 172.17.154.3 on vr0
arp: dc:9f:db:3e:27:4f attempts to modify permanent entry for 172.17.154.3 on vr0
HybridRekpark303# ifconfig vr0
vr0: flags=8843<UP,BROADCAST,RUNNING,SIMPLEX,MULTICAST> metric 0 mtu 1500
	options=8280b<RXCSUM,TXCSUM,VLAN_MTU,WOL_UCAST,WOL_MAGIC,LINKSTATE>
	ether 00:0d:b9:1c:ce:b0
	inet 172.17.154.1 netmask 0xffffff00 broadcast 172.17.154.255
	inet 172.17.154.3 netmask 0xffffff00 broadcast 172.17.154.255
	nd6 options=29<PERFORMNUD,IFDISABLED,AUTO_LINKLOCAL>
	media: Ethernet autoselect (100baseTX <full-duplex>)
	status: active

Op de node van interface VR0 deze gedelete aangezien deze binnen het zelfde subnet valt als het bestaande ipnummer.
HybridRekpark303# ifconfig vr0 delete 172.17.154.3

HybridRekpark303# ifconfig vr0 delete 172.17.154.3

Internet verbinding vanaf de node is in orde.

HybridRekpark303# ./speedtest-cli 
Retrieving speedtest.net configuration...
Retrieving speedtest.net server list...
Testing from KPN (92.66.227.164)...
Selecting best server based on ping...
Hosted by SIT Internetdiensten B.V. (Voorthuizen) [36.36 km]: 344.992 ms
Testing download speed........................................
Download: 15.27 Mbit/s
Testing upload speed..................................................
Upload: 0.77 Mbit/s

comment:2 Changed 6 years ago by ed

Krijgen de mensen wel de WLportal pagina te zien waar ze accoor moet gegaan met de voorwaarden?
Is er wellicht een foutmelding die de gebruikes krijgen zoals dat ze al ingelogd zijn?

comment:3 Changed 6 years ago by henk

Gebruiker kon inloggen tot 'Captive Portal' en 'akkoord'.
Daarna gebeurde niets.

Zojuist getest.
Internet werkt weer!

comment:4 Changed 6 years ago by henk

Probleem is ontstaan nadat boot met repeater tijdelijk uit de haven weg was en toen weer terugkeerde.
Welke aktie moet worden ondernomen om het een volgende keer te voorkomen?

comment:5 Changed 6 years ago by ed

Resolution: fixed
Status: newclosed

Als de repeater wordt verplaatst dan kunnen aangemelde gebruikers hun verbinding / uplink verliezen. Dit kan resulteren in openblijvende redirects in de firewall van de node. Wellicht is dit de reden dat mensen geen
internet verkeer meer kregen. Dit is niet echt te voorkomen (verplaatsen van repeaters) op dit moment, maar door het te melden wordt er zo snel mogelijk naar gekeken en een oplossing gezocht.

In mijn vorige melding was ik vergeten te melden dat ik de firewall states ook had geflushed (zie ook ticket #647)

HybridRekpark303# pfctl -t wlportal -T flush

Nu werkt inderdaad alles weer goed. 8 verbonden gebruikers.

HybridRekpark303# pfctl -t wlportal -T show | wc
       8       8     136
Note: See TracTickets for help on using tickets.