source: hybrid/branches/releng-9.0/nanobsd/ports/dns/maradns2/Makefile@ 10612

Last change on this file since 10612 was 10612, checked in by rick, 13 years ago

Make port building whole bunch more stupid:

1) Bundle ports in the tree itself, instead of global shared banch.
2) Copy the local ports just in the /usr/ports tree to allow playing around

with just the ordenary tools.

File size: 2.5 KB
Line 
1# New ports collection makefile for: maradns2
2# Date created: 10 Feb 2012
3# Whom: Rick van der Zwet <info@rickvanderzwet.nl>
4#
5# $FreeBSD$
6#
7
8PORTNAME= maradns
9PORTVERSION= 2.0.05
10CATEGORIES= dns
11MASTER_SITES= http://www.maradns.org/download/2.0/${PORTVERSION}/ \
12 SF/${PORTNAME}/MaraDNS/${PORTVERSION}/
13
14MAINTAINER= info@rickvanderzwet.nl
15COMMENT= DNS server with focus on security and simplicity
16
17LICENSE= BSD
18LICENSE_FILE= ${WRKSRC}/COPYING
19
20CONFLICTS= maradns-1.?
21
22OPTIONS= IPV6 "Enable IPv6 Support" Off
23.include <bsd.port.options.mk>
24
25.if defined(WITH_IPV6)
26CONFIGURE_ARGS+= --ipv6
27.endif
28
29LATEST_LINK= maradns2
30
31USE_RC_SUBR= ${PORTNAME} deadwood zoneserver
32USERS= bind
33GROUPS= bind
34
35MAN1= deadwood.1 askmara.1 fetchzone.1 getzone.1
36MAN5= csv1.5 csv2.5 csv2_txt.5 mararc.5
37MAN8= duende.8 maradns.8 zoneserver.8
38
39post-extract:
40 ${MV} ${WRKSRC}/doc/en/man/Deadwood.1 ${WRKSRC}/doc/en/man/deadwood.1
41 # The internal deadwood release seems to differ all the time, but the
42 # patches needs to stay more and less the same
43 ${LN} -s ${WRKSRC}/deadwood* ${WRKSRC}/deadwood
44
45do-install:
46 ${INSTALL_PROGRAM} ${WRKSRC}/deadwood-*/src/Deadwood ${PREFIX}/sbin/deadwood
47 ${INSTALL_PROGRAM} ${WRKSRC}/server/maradns ${PREFIX}/sbin/maradns
48 ${INSTALL_PROGRAM} ${WRKSRC}/tcp/fetchzone ${PREFIX}/bin/fetchzone
49 ${INSTALL_PROGRAM} ${WRKSRC}/tcp/getzone ${PREFIX}/bin/getzone
50 ${INSTALL_PROGRAM} ${WRKSRC}/tcp/zoneserver ${PREFIX}/sbin/zoneserver
51 ${INSTALL_PROGRAM} ${WRKSRC}/tools/askmara ${PREFIX}/bin/askmara
52 ${INSTALL_PROGRAM} ${WRKSRC}/tools/duende ${PREFIX}/bin/duende
53
54 ${INSTALL_DATA} ${WRKSRC}/doc/en/examples/example_full_mararc ${PREFIX}/etc/mararc.sample
55 ${INSTALL_DATA} ${WRKSRC}/deadwood-*/doc/dwood3rc ${PREFIX}/etc/dwood3rc.sample
56
57 ${MKDIR} ${PREFIX}/etc/maradns ${PREFIX}/etc/deadwood
58
59.if !defined(NOPORTEXAMPLES)
60 ${MKDIR} ${EXAMPLESDIR}
61 (cd ${WRKSRC}/doc/en/examples/ && ${COPYTREE_SHARE} example_\* ${EXAMPLESDIR})
62.endif
63.if !defined(NO_INSTALL_MANPAGES)
64 ${INSTALL_MAN} ${WRKSRC}/doc/en/man/*.1 ${PREFIX}/man/man1/
65 ${INSTALL_MAN} ${WRKSRC}/doc/en/man/*.5 ${PREFIX}/man/man5/
66 ${INSTALL_MAN} ${WRKSRC}/doc/en/man/*.8 ${PREFIX}/man/man8/
67.endif
68.if !defined(NOPORTDOCS)
69 ${MKDIR} ${DOCSDIR}
70 (cd ${WRKSRC}/doc/en/ && ${COPYTREE_SHARE} "misc text tutorial webpage" ${DOCSDIR})
71 (cd ${WRKSRC}/doc/en/ && ${COPYTREE_SHARE} \*.txt ${DOCSDIR})
72.endif
73#(cd ${WRKSRC}/doc/en/ && ${COPYTREE_SHARE} misc text tutorial webpage ${DOCSDIR})
74
75PORTDOCS= misc text tutorial webpage *.txt
76PORTEXAMPLES= example_*
77
78.include <bsd.port.mk>
Note: See TracBrowser for help on using the repository browser.