wiki:NanoBSD

Version 47 (modified by huub, 15 years ago) ( diff )

--

Welcome to 'building the WirelessLeiden NanoBSD image'

FreeBSD default method for installing FreeBSD on embedded devices, like Soekris, Alix and others. The manual described below is (loosely) based on the Concept plan of Tim Baas, but also consists of many hints by official 'Introduction to NanoBSD' manual and other stuff found on the net ;-)

Have to remember links

Procedure

Please note that you can find the supporting files in the subdirectory nanobsd

Build environment

Get yourself a fresh freebsd host with ports and subversion installed

  1. Run the basic CD installer of 7.2.

The procedure below has been tested with 7.2-RELEASE (standard developer install will fit our needs). Installing FreeBSD is not scope of the document, take a look into the FreeBSD handbook Chapter 2 Installing FreeBSD if you do not know the details.

Please do mind that all commands below need to be executed as root, due to the many mounts and unmounts done in various phases.

  1. get latest sources
    $ csup  -h cvsup.nl.freebsd.org /usr/share/examples/cvsup/standard-supfile
    
  2. install subversion
    $ pkg_add -r subversion
    
  3. fetch ports
    $ portsnap fetch extract
    
  4. OPTIONAL, every developer has his own preferences, these are mine ;-)
    $ pkg_add -r vim-lite sudo screen
    

Introduction

XXX: Make all paths into variables for easy reading

First download the environment and run initial build

$ setenv R /root/nanobsd
$ svn checkout http://svn.wirelessleiden.nl/svn/projects/iris/nanobsd $R
$ cd $R

Note 1: compilation can take a long time, depending on your hardware.

Note 2: if svn is not found: svn is in /usr/local/bin, alternatively log out and in or use rehash in a csh shell. To make it available.

Note 3: even this little script got flags, check the output of sh /usr/src/tools/tools/nanobsd/nanobsd.sh -h

-b suppress builds (both kernel and world)
-k suppress buildkernel
-w suppress buildworld
-c specify config file
...

Continue:

  1. Compile all required packages using
    $ /root/nanobsd/tools/package-build.sh
    
  2. Set your favorite root password to be used in the image
    $ setenv CFG_ROOT_PASSWORD `dd if=/dev/random bs=10k count=10 | & tr -cd '[a-zA-Z0-9]' | cut -c -15`; echo $CFG_ROOT_PASSWORD
    
    (if you like a simple password substitute the `dd if=/dev/random bs=10k count=10 | & tr -cd '[a-zA-Z0-9]' | cut -c -15` with your password
  3. Build nanobsd (make sure to prepare some coffee;-) )
    $ sh /usr/src/tools/tools/nanobsd/nanobsd.sh -c /root/nanobsd/cfg/nanobsd.wleiden 
    
    take a coffee, this normally 2 - 8 hours depending on the machine configuration
  4. Fetch configuration onto image (pick your situation)
    $ /root/nanobsd/tools/config-image.sh 
    
    1. New image: Put full image on flash disk
      $ dd bs=64k if=/usr/obj/nanobsd.wleiden/_.disk.full of=/dev/da0
      
      (giving /dev/da0 is your compact flash entry
    2. Existing image: Put partial image on slice (slice 2)
      $ dd bs=64k if=/usr/obj/nanobsd.wleiden/_.disk.image of=/dev/da0s2
      
    3. Existing image remote update (slice 2)
      $ gzip -c /usr/obj/nanobsd.wleiden/_.disk.image | ssh root@192.168.4.100 'gzip | sh /tools/updatep2'
      
  5. All done! Place the image in the new machine and boot it up, you should be good to go!
  6. For next nodes you can skip the build if you are not going to use the same image again and go directly for step 4, or take a look at development if you have to rebuild the image after (small changes)

Development

For small changes there is a shortcut in the build (to save you some coffee ;-)). Pick the situation applicable

  1. First lets pump it's source to the latest version
    $ svn up /root/nanobsd
    
    1. Only changes in kernel options - kernel.wleiden altered - ETA 0:45
      $ sh /usr/src/tools/tools/nanobsd/nanobsd.sh -w -c /root/nanobsd/cfg/nanobsd.wleiden
      
    2. Only changes in world options - CONF_{BUILD,COMMON,INSTALL} in nanobsd.wleiden altered - ETA 2:00 - 6:00
      $ sh /usr/src/tools/tools/nanobsd/nanobsd.sh -k -c /root/nanobsd/cfg/nanobsd.wleiden
      
    3. _NO_ changes in build options - any other file altered - ETA 0:10
      $ sh /usr/src/tools/tools/nanobsd/nanobsd.sh -b -c /root/nanobsd/cfg/nanobsd.wleiden
      

Light based packages suggestions

  • dnsmasq instead of isc-dhcp30-server and bind
  • thttpd instead of apache

Further research

  • stumber /usr/src/tools/tools/net80211/stumber

Background

Testing Images

TestingViaNFS

Hints

  • You could always decide to install your FreeBSD base instance into a virtual environment
  • cvsup.nl.freebsd.org is the local dutch cvsup mirror, replace nl with your proper country code
  • It seems tempting to follow /usr/share/examples/cvsup/stable-supfile instead of /usr/share/examples/cvsup/standard-supfile please DO NOT unless your like big trouble as stable-supfile is the stable DEVELOPMENT branch e.g. upcoming stable.
  • Default username/password = root/welkom01
  • Always use cu or putty for serial communication minicom, screen, putty all issues of some kind.

Comments, questions or remarks?

Feel free to edit this page or send an email to our techniek mailinglist

  • Handy .cshrc hints
    alias quicknano sh /usr/src/tools/tools/nanobsd/nanobsd.sh -b -c /root/nanobsd/cfg/nanobsd.wleiden
    alias slownano  sh /usr/src/tools/tools/nanobsd/nanobsd.sh -c /root/nanobsd/cfg/nanobsd.wleiden
    alias slownewkernelnano sh /usr/src/tools/tools/nanobsd/nanobsd.sh -w -c /root/nanobsd/cfg/nanobsd.wleiden
    alias slownewworldnano sh /usr/src/tools/tools/nanobsd/nanobsd.sh -k -c /root/nanobsd/cfg/nanobsd.wleiden
    alias prepare-nfs  /root/nanobsd/tools/prepare-nfs.sh -f -n
    
Note: See TracWiki for help on using the wiki.