wiki:FreeBSD10_Guide

Version 33 (modified by huub, 10 years ago) ( diff )

--

Nodefactory based on FreeBSD-10


Scope

  • based on FreeBSD-10.1 (until release use 10-STABLE
  • ubound replaces bind
  • implement latest version of lvrouted (auto update default route)
  • update captive portal
  • cleanup packages
  • possibly replace thttpd (light version of apache?)

A. Setup a FreeBSD host


Warning: 1) Make sure /usr is at least 5GB in size, as building images requires quite some space. 2) Make sure you install the 32bit i386 release of FreeBSD also when your system does support amd64, as cross compiling can give some nasty surprises. Tip: use a separate hard disk, mounted on /usr/obj to speed up the compilation process.


Get yourself a fresh i386 freebsd host with ports and subversion installed as follows:

A.1. Run the basic CD installer

The procedure below has been tested with 10.0 (standard developer install - no ports -, e.g. with default partitioning will fit our needs). Installing FreeBSD is outside the scope of this document, take a look into the FreeBSD handbook Chapter 2 Installing FreeBSD if you do not know the details.

After installation and reboot apply update:

build# freebsd-update fetch
build# freebsd-update install
build# reboot

Please do mind that all commands below need to be executed as root, because of the many mounts and unmounts done in various phases. It maybe convenient to permit ssh root login (modify /etc/ssh/sshd_config accordingly).

Internet connection is required.

Set correct date/time, e.g: build# ntpdate 0.nl.pool.ntp.org

(You may also wish to add ntpd_enable="YES" to /etc/rc.conf)

A.2 Install Subversion and Ports

Subversion is installed as a package:

build# pkg install subversion

Tip: The package management tool is not yet installed on your system. So answer yes to the prompt: "Do you want to fetch and install it now? [y/N]:"

Check out a copy of the ports tree (this will take a couple of minutes).

build# svn checkout https://svn0.eu.FreeBSD.org/ports/head /usr/ports

Certificate information ...... answer p to prompt: (R)eject, accept (t)emporarily or accept (p)ermanently?

Alternatively use portsnap:

build# portsnap fetch extract

A.3 set some useful variables

Alter the shell configuration file:/root/.cshrc:

Ensure ftp is set to passive mode, to avoid potential firewall issues:
build# echo 'setenv FTP_PASSIVE_MODE YES' >> /root/.cshrc

Set a default password for the images that you will produce
build# echo 'setenv CFG_ROOT_PASSWORD DefaultPassword12!' >> /root/.cshrc
 
Define your nanobsd (svn) working directory:
NOTE: All commands at later stages will refer to this so you better get it right!
build# echo 'setenv R /root/nanobsd' >> /root/.cshrc

Next load your file (or login again): build# source /root/.cshrc

A.4. install lvrouted port

Warning: to be sorted out! To compile lvrouted you need ocaml support, without X11, without TOOLBOX:

build# make -C /usr/ports/lang/ocaml-nox11 install clean BATCH=YES
build# make -C /usr/ports/devel/ocaml-findlib install clean WITHOUT="TOOLBOX X11 TK" BATCH=YES

(??? build# make -C /usr/ports/devel/autoconf259 install clean BATCH=YES build# make -C /usr/ports/devel/autoheader259 install clean BATCH=YES build# make -C /usr/ports/dns/bind-tools/ install clean BATCH=yes #(required for nagios-plugins in FreeBSD10)

checkout latest version of lvrouted (12878):

build# svn checkout http://svn.wirelessleiden.nl/svn/node-config/other/lvrouted/trunk /usr/local/share/lvrouted

run the release.sh script to produce the tar 'release' file (lvrouted-12878.tar.gz):

build# cd /usr/local/share/lvrouted/
build# tools/release.sh

Note: you may wish to verify the SHA256 en filesize in $R/ports/net/lvrouted/distinfo

A.5. OPTIONAL, every developer has his own preferences, these are mine

build# make -C /usr/ports/editors/vim-lite install clean BATCH=yes build# make -C /usr/ports/security/sudo install clean BATCH=yes build# make -C /usr/ports/sysutils/screen install clean BATCH=yes

A.6. get latest sources

build# svn co svn://svn0.eu.FreeBSD.org/base/stable/10 /usr/src

B. Build environment

B.1 Download the environment from the Wireless Leiden svn repository

build# svn checkout https://svn.wirelessleiden.nl/svn/code/hybrid/branches/releng-10/nanobsd $R
build# cd $R

Note: Certificate information ...... answer p to prompt: (R)eject, accept (t)emporarily or accept (p)ermanently? If svn is not found: svn is in /usr/local/bin, alternatively log out and in, or use rehash in a csh shell to make it available.

B.2. Compile all required packages using

build# $R/tools/package-build.sh

This will take quite some time (on remote host use <screen>), depending on your hardware of course. Packages are created in /root/nanobsd/pkg/All:

build#:~/nanobsd/pkg/All # ls
......

B.3. Set your favorite root password to be used in the image

Note: you can skip this step if you are satisfied with the default password set in step A.3 above.

$ setenv CFG_ROOT_PASSWORD `dd if=/dev/random bs=10k count=10 |\
  tr -cd '[a-zA-Z0-9]' | cut -c -15`
$ echo $CFG_ROOT_PASSWORD

If you like a simple password, substitute the `dd if=/dev/random bs=10k count=10 | tr -cd '[a-zA-Z0-9]' | cut -c -15` with your password.

B.4 Build nanobsd (make sure to prepare some coffee;-) )

$ sh /usr/src/tools/tools/nanobsd/nanobsd.sh -c $R/cfg/nanobsd.wleiden 

Note 1: Take a coffee of go for a hike, this normally takes 2 - 8 hours depending on the machine configuration. If you like to save some power use the script provided by Rick (http://rickvanderzwet.nl/svn/personal/misc/power-saver). This script is mainly used on a home server for building FreeBSD world and kernels. As soon it is done it can shutdown if not being used anymore. The system has Wake-On-Lan support and can thus be activated again from remote.

Note 2: even this little script got flags, check the output of sh /usr/src/tools/tools/nanobsd/nanobsd.sh -h

-b suppress builds (both kernel and world)
-k suppress buildkernel
-w suppress buildworld
-c specify config file
...

Note 3: The geometry of the cf card is defined in the nanobsd configuration file $R/cfg/nanobsd.wleiden The 'default' values are for a Peak 1 GB card. They also work on an Alix2D3 board with a 1 GB PCEngines 'blanc' cf card and 1 or 2 GB Transcend cf cards although those geometries are different. There are issues with Soekris boards, depending on BIOS version.

Note: See TracWiki for help on using the wiki.